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Application & Device Safety Considerations 
 Reading these Instructions

Before operating a device or application, read these instructions carefully and understand their safety implications. In some
situations, improper use may result in damage or injury. Keep this manual in a convenient location for future reference. Note
that these instructions may not cover all details or variations in equipment or cover every possible situation regarding
installation, operation, or maintenance. Should problems arise that are not covered sufficiently in the text, immediately contact
Energy and Transportation Solutions (ETS) Customer Support for further information.

 Protecting Operating Processes
The failure of a device or application – for whatever reason – may leave an operating process without appropriate protection and
could result in possible damage to property or injury to persons. To protect against this, review the need for additional backup
equipment or provide alternate means of protection (such as alarm devices, output limiting, fail-safe valves, relief valves,
emergency shutoffs, emergency switches, etc.). Contact ETS for additional information.

 Using Qualified Personnel
Installation, configuration, and any subsequent modifications to a device or application should only be performed by qualified,
suitably trained personnel.

 System Training
A well-trained workforce is critical to the success of your operation. Knowing how to correctly install, configure, program,
calibrate, and troubleshoot your Emerson equipment provides your engineers and technicians with the skills and confidence to
optimize your investment. ETS offers a variety of ways for your personnel to acquire essential system expertise. Our full-time
professional instructors can conduct classroom training at several of our corporate offices, at your site, or even at your regional
Emerson office. You can also receive the same quality training via our live, interactive Emerson Virtual Classroom and save on
travel costs. For our complete schedule and further information, contact the ETS Training Department at 800-338-8158 or email
us at education@emerson.com.

 Grounding Equipment
Ground metal enclosures and exposed metal parts of electrical instruments in accordance with relevant safety standards. For the
USA, refer to OSHA rules and regulations as specified in Design Safety Standards for Electrical Systems, 29 CFR, Part 1910, Subpart S,
dated: May 16, 1981 (OSHA rulings are in agreement with the National Electrical Code). For international locations, refer to IEC
60364-4-41: PROTECTION AGAINST ELECTRIC SHOCK. You must also ground mechanical or pneumatic instruments that include
electrically operated devices such as lights, switches, relays, alarms, or chart drives. The chassis (or earth ground) lug provides a
safe connection point to a customer-designated ground location for ESD and transient voltage suppression. Do not use the
chassis ground lug for signal, common, or return connections. Do not connect the chassis ground lug directly to a lightning
arrestor/lightning rod. Do not run signal wiring in conduit or open trays with power wiring or near heavy electrical equipment.
If shielded wiring is used, ground the shield of the signal wiring at any one point of the signal loop.

Important: Complying with the codes and regulations of authorities having jurisdiction is essential to ensuring personnel safety.
The guidelines and recommendations in this manual are intended to meet or exceed applicable codes and regulations. If
differences occur between this manual and the codes and regulations of authorities having jurisdiction, those codes and
regulations must take precedence.

 Protecting from Electrostatic Discharge (ESD)
Any device contains sensitive electronic components which can be damaged by exposure to an ESD voltage. Depending on the
magnitude and duration of the ESD, it can result in erratic operation or complete failure of the equipment. Ensure that you
correctly care for and handle ESD-sensitive components.

 Ethernet Connectivity
This automation device is intended to be used in an Ethernet network which does not have public access. The inclusion of this
device in a publicly accessible Ethernet-based network is not recommended.

 Returning Equipment
If you need to return any equipment to ETS, it is your responsibility to ensure that the equipment has been cleaned to safe levels,
as defined and/or determined by applicable federal, state and/or local law regulations or codes. You also agree to indemnify ETS
and hold ETS harmless from any liability or damage which ETS may incur or suffer due to your failure to ensure device
cleanliness.

mailto:education@emerson.com
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Chapter 1. Introduction – What is FBx 
Script Developer? 

FBx Script Developer allows you to create pre-defined sets of instructions – called 
scripts – which you can use to access an FB3000 RTU or an 
FB1100/FB1200/FB2100/FB2200 flow computer.  

You edit scripts directly in FBx Script Developer. 

Scripts have the file extension *.SCR. The FBx Script Developer stores the scripts on the 
PC.  

Figure 1-1.  FBx Script Developer Overview   

 

1 Script executes on the PC/laptop 
2 Commands from the script sent to the device (RTU or flow computer) 

1.1 How Are Scripts Used? 
Scripts are typically used for testing and to verify that the RTU/flow computer is 
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operating as expected.  
 
Scripts can also serve as a method for automating certain day-to-day tasks you might 
need to perform. For example, you might want to create a script that collects periodic 
history records from your flow computers. You can test it out in the FBx Script 
Developer, and then save the script (.SCR) file. 
 
You can launch a script manually through Field Tools, or you can run it from the 
command line using FBxScriptRunner. 

1.2 Commands 
Appendix A includes a full list of the available commands you can use in your scripts.  

When you create your scripts, you can type the command parameters in directly, or 
optionally, you can click the Command icon and enter the text there, or depending on 
the command, make selections that enter the text for you. 

1.3 Local Variables 
Since scripts are essentially programs that FBx Script Developer can run, scripts can 
include local variables to store values. Based on these values you can make logical 
decisions for executing portions of the script or use the local variables as arguments for 
particular script commands. 
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Chapter 2 – Starting FBx Script Developer 
and Creating a Script 

2.1 Before You Begin 
When you install Field Tools, you automatically install FBx Script Developer. 

2.2 Starting the FBx Script Developer 
To start the FBx Script Developer, click: Start > Emerson Field Tools > FBxScripting. 

Note 

You can also start the tool from the command line. Typically, you would use this 
technique to automate execution of scripts you already created. See Chapter 3 for more 
information. 

2.3 Creating a Simple Script 
These steps outline how to make a very simple script. 

1. Start FBx Script Developer by clicking: Start > Emerson Field Tools > FBxScripting. 
FBx Script Developer opens: 

Figure 2-1.  FBx Script Developer Screen    
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1 Title bar 
2 Menu bar 
3 Toolbar 
4 Script pane 
5 Variable status pane  

 

2. Either click Script > Commands > Add Command or click the Add command  
toolbar icon to add a line for the script. 

Figure 2-2.  Inserting a Line into the Script   

 

Line   The line number of the script 

Time   The timestamp when the command is executed 

Command/Argument The Command name and any arguments. 

3. Click in the center of the Command/Argument column, then click on the down 
arrow to open the command selection menu. 

Figure 2-3.  Command Selection Menu   

 

 

4. Scroll through the command list and select the first command. In this case, we 
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choose the PAUSE command, which pauses execution of a script for a specified 
number of seconds. 

Figure 2-4.  Selecting a Command   

 

5. Now, enter “60” which means that execution should pause for 60 seconds and press 
the [Enter] key. 

6. Click the Add command  icon to select another command, in this case we 
choose the ECHO command, which displays whatever text is specified after it. 

Figure 2-5.  Selecting a Command   

 

   :    : 

 

7. Now enter the text “Hello everybody” after the ECHO command and press 
[Enter]. 
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Figure 2-6.  Entering an argument for a command  

 

8. We can now test this simple 2-line script. Click the “Run” toolbar icon or click 
Script > Run > Run. The script starts and you can watch the timing of the PAUSE 
command count down in the Status field. 

Figure 2-7.  Script Executes a PAUSE command   

 

9. When the 60 seconds have expired, the Status column shows the echoed text 
“Hello everybody:” 

Figure 2-8.  Script Executes an ECHO command   

 

10. When you finish adding commands to the script, save the script. 

2.4 Saving the Script 

Click File > Save or click the Save icon. 

Enter a name for the script and click Save. 

FBx Script Developer saves the script with an extension of .SCR. 

By default, scripts are saved in the folder: 

\\Users\Public\Public Documents\Emerson\FieldTools\FBxScripts\ 

2.5 Modifying Lines of a Script 
When you edit a script, you can use standard editing techniques to cut, paste, copy, etc. 
entire lines in a script. The table, below, shows the supported editing commands:  

Table  2-1.  Editing Functions   
Editing 
Function 

Toolbar Icon Menu Bar Sequence Description 

Cut 
 

Edit > Cut Cuts the selected line 
of the script and stores 
it in the paste buffer. 

Copy  Edit > Copy Copies the selected 
line of the script and 
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Editing 
Function 

Toolbar Icon Menu Bar Sequence Description 

puts it in the paste 
buffer. 

Paste  Edit > Paste Pastes the contents of 
the paste buffer to the 
current script line. 

Insert 
Command 

 Script >Commands > Insert 
Command 

Inserts a blank line in 
the script between two 
other lines. 

 

2.6 Making a Copy of the Current Script File with 
a Different Name 
Click File > Save As.  

Enter a name for the script and click Save. 

2.7 Entering Arguments in the Command 
Arguments dialog box 
While you can enter some arguments directly after the command, as we showed in 
Section 2.3, for anything more than the simplest commands, you should use the 
Command Arguments dialog box. 

1. Enter the command on the desired line of the script and press the [Enter] key. 

2. Position the cursor in the line after the command and click the Command icon. 

3. This launches a dialog box that allows you to enter arguments. The appearance of 
the dialog box varies depending on the command. In some cases, you enter 
arguments in a text field: 

Figure 2-9.  Command Arguments dialog box -text only   
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In other cases, you make selections to generate the text for you: 

Figure 2-10.  Command Arguments dialog box – make selections    

 

4. When you finish editing the script, you can run the script as we did, directly in the 
FBx Script Developer using the Run  icon. Alternatively, you can run the script by 
invoking FBxScriptRunner from the command line. See Chapter 3 for information on 
command line options. 

Note 

Because there are dozens of different commands you can include in a script, it is fairly 
easy for you to create very complex scripts that might be hundreds of lines long. If you 
want to create lengthy scripts, you should review the debugging techniques in Chapter 
4. 

2.8 Using the Set Arguments dialog box 
You can set arguments for the entire script using the Set Arguments dialog box.  

1. Click Script > Set Arguments 
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Figure 2-11.  Script Arguments dialog box   

 

2. Enter the arguments for the script, and click OK. 

2.9 Creating an all New Script 
Click the New Script  icon or click File > New. 

2.10 Opening an Existing Script 
Click the Open Script icon or click File > Open and select the script you want to 
open. By default, scripts are stored in the folder: 

 \Users\Public\Public Documents\Emerson\FieldTools\FBxScripts 

If the script you want to open was open recently, you can click File > Recent and select 
the desired script. 

You can also open a script file by double-clicking on the SCR file. 

2.11 Printing the Script 
Click the Print Script  icon, or click File > Print to open the Windows print dialog box 
and make your selections to print the current script. 

2.12 Packaging a Script and its Associated Files 
If desired, you can combine a script, together with the files it uses (.ZSL solution files, 
recipe files) into a single zipped file (*.SCZ), place the script and files in a folder, then 
click File > Package and browse to the folder containing the files, then select the folder 
to create the package file.  
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Chapter 3. Running Scripts  

While you can run scripts manually in the FBx Script Developer, that’s really only 
intended for trying out the script and debugging it. 

The main ways you might run a script are: 

 Run the script manually from within the Field Tools tree.  

 Run the script from the command line or possibly using a third-party scheduling 
program.  

Whether invoked from the FBx Script Developer, from the command line, or from the 
Field Tools tree, the scripts are executed by the FBxScriptRunner program. 

3.1 Launching a Script from Within Field Tools 
You can launch a script you created from within the Field Tools tree: 
 
1. Right-click on the device on which you want to run the script, and select Run 

Script. (Alternatively, you can single click on the device to highlight it and then 
click the Run Script button.) 

Note 
If your script includes a “CONNECT {$A1}” command, the connection name is 
automatically passed to the script to fill in the A1 parameter. 

Figure 3-1.  Launching a Script within Field Tools   

 

2. Select the script file you want to run. 
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Figure 3-2.  Selecting a Script File   

 

3. Click Open and FBxScriptRunner launches the script. 

3.1.1 Generating a Support Bundle for a Device 
If you are experiencing problems with a device, a predefined script exists that you 
can use to gather diagnostic and system information in a ZIP file called a support 
bundle that you can forward to our technical support group for analysis. 
1. Right-click on the device for which you want to gather support information and 

select Support Bundle. Alternatively, you can single click on the device to 
highlight it and click the Support Bundle button. 

Figure 3-3.  Generating a Support Bundle   

 
2. The script launches to collect diagnostic information, memory dumps, alarm 

and event information and more.  
3. The collected information is stored in a zip file. By default, the support bundle 

zip file is stored in the \Emerson\Logs folder: 
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\Users\Public\Public Documents\Emerson\Logs\connection_name_Issue_timestamp 

3.2 FBxScriptRunner Command Line Arguments 
You might want to use a third-party scheduling program to launch FBxScriptRunner 
from the command line to handle certain day-to-day tasks. 

The syntax for launching FBxScriptRunner is as follows: 

C:\>FBxScriptRunner script_name [arg1 arg2 arg3 … argn] 

script_name  the name of the script file including the extension (.SCR or .SCZ). 

arg1… argn arguments used by commands in the script file, where “n” is the 
number of the last argument for this script. Using arguments, 
allows you to substitute parameters as needed, so you can make 
the scripts more versatile. The same script you use, for example, to 
communicate with RTU1, can be re-used with RTU2 and RTU3, by 
passing in the RTU name as an argument. 

FBxScriptRunner stores the arguments in local string variables so they can be 
referenced by commands in your script file. Local string variable names must be 
preceded by a dollar sign “$” to identify them as string variables. 

Local String Variable Name:   Argument: 

$A1     arg1 

$A2     arg2 

$A3     arg3 

: 

$An     argn 

Notes 
 FBxScriptRunner updates a numeric local variable with a count of the number of 

arguments used called ARG_CNT. ARG_CNT does not include the script name as 
one of the arguments in the count. 

 Local variables, such as these arguments, may be used in script commands by 
enclosing them in curly brackets. For example, to use arg1 with the PAUSE 
command, you enter PAUSE {$A1} 

 If an argument includes spaces, you must enclose it in double quotes “ “. 
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3.2.1 Example – Collecting Alarms and Events 
Let’s say we want to create a script that lets us connect to an RTU or flow computer and 
retrieve its alarm history and event history while also sending messages to the screen 
reporting what it’s doing. 

We’re going to need to use the CONNECT command to connect to the device, the ECHO 
command to report what the script is doing, and the ALARM_REPORT and 
EVENT_REPORT commands to collect the alarms and events and store them in files. 

1. Make sure Field Tools communications are active. 
2. Start the FBx Script Developer and enter the script as follows. Note that we are 

using the argument $A1 to hold the device connection name for the RTU or flow 
computer. 

Figure 3-4.  Example Script to Collect Alarms and Events   

  

3. Save the script with the name AlarmEventCollect.scr. 
4. Open a command prompt and move to the folder where you saved the script. 
5. Invoke the FBxScriptRunner with the script name and the connection name for the 

device. In this case, we connect to a device connection named “WESTON.” We give 
the script name followed by the argument “WESTON” to tell which connection to 
activate. 

 
The FBxScriptRunner window opens and reports the progress of the script: 
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Figure 3-5.  FBxScript Runner Output   

 

When the script completes execution, two PDF files (1 for alarms, 1 for events) are 
created in the specified output folder, in this case C:\MyReports: 

 

 

3.2.1.1 Including a Date/Time Stamp in the Output Filename 
If you were to run the exact same script, twice in a row with the same device, in this 
case, “WESTON” there will be a problem and an error is generated: 

 

Why does this happen? Because the report you are trying to generate already exists. 
You can avoid this, however, by making some small changes to your script. If you 
change the lines: 
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ALARM_REPORT C:\MyReports\{$A1}_Alarms PDF NEWTOOLD ALL 

EVENT_REPORT C:\MyReports\{$A1}_Events PDF NEWTOOLD ALL 

Include the text: “$D$T” to include a timestamp in the filename: 

ALARM_REPORT C:\MyReports\{$A1}_$D$T_Alarms PDF NEWTOOLD ALL 

EVENT_REPORT C:\MyReports\{$A1}_$D$T_Events PDF NEWTOOLD ALL 

Now the report filenames will include a timestamp and there will not be any name 
conflicts: 
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Chapter 4. Debugging Scripts  

4.1 Error Reporting 
If FBx Script Developer encounters a problem when it executes a line of your script, it 
highlights that line in red, and displays an error message in the Status column. This 
helps you identify common syntactical errors. 

Figure 4-1.  FBx Scripting – Debugging a Script   

 

1 Run script (or resume after a break) 
2 Step to next line of script but do not execute 
3 Break (pause) script execution 
4 Stop script execution entirely 
5 Set breakpoint 
6 Remove a single breakpoint 
7 Remove all breakpoints 
8 Breakpoint active 
9 Line containing an error highlighted in red 

10 Error message 
11 Variables pane – shows current values of local variables 

 

You can resume execution after the line containing the error by clicking on the Run  
icon.  
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Although the FBxScriptRunner detects syntactical errors during execution, sometimes 
script errors relate more to the logic of the script. To solve those kinds of problems 
often requires you to look at more than just the current script line. You might need to 
pause execution at a particular point, and then proceed line by line, while examining 
the state of different script variables. To do this, you need to use the breakpoint feature 
and step mode. 

4.2 Working with Breakpoints 
A breakpoint is a flag that you place on a line at which you would like execution to 
pause. As the script executes, it pauses on the line containing the breakpoint, but does 
not execute the command on the line. This allows you to look at the Variables pane to 
view the state of script variables immediately before the breakpoint. When the 
execution pauses, the script enters step mode. Step mode allows you to execute one 
script line at a time, by clicking on the Step  icon.  

By breaking execution at certain points, and then looking at script variables, it is 
possible to better understand how the script works and identify errors in the script’s 
logic. As you advance line by line, you may be able to identify the source of a problem 
so you can correct it. 

4.2.1 Setting a Breakpoint 
There are three different ways to set a breakpoint: 

 Click anywhere in the line of the script where you want the breakpoint, then click 

on the Breakpoint  icon, –or– 
 Click anywhere in the line of the script where you want the breakpoint, then click 

Script > Breakpoint > Set Breakpoint. 
 Double-click in the leftmost column of the line where you want the breakpoint. 
 

 
All of these methods place a stop  flag in the leftmost column. This means that line 
has a breakpoint. 

The next time you execute the script, execution pauses on the line containing the flag, 
prior to executing the command on that line. 
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4.2.2 Stepping through the Script using Step Mode 
Once execution pauses on a particular line of the script, you can proceed one line at a 
time by clicking on the Step icon  or click Script > Run > Step.  

You can now look in the Variables pane to see how values of local variables in the script 
change. 
 

4.2.3 Clearing a Single Breakpoint 
Click in the Line containing the breakpoint, then click the Remove Breakpoint icon 
or click Script > Break point > Remove Breakpoint. 

Either of these methods remove the  flag for that line and clear the breakpoint.   

4.2.4 Clearing All Breakpoints  

To clear all breakpoints in the script, click the Remove All Breakpoints icon, or click 
Script > Break point > Remove all Breakpoints. 

4.3 Manually Breaking Execution of the Currently 
Executing Script 

To break (pause) the currently executing script, click the Break  icon or click 
Script>Run>Break. 

You can then proceed to make edits to the script. To resume the script, from the point 

where it stopped, click the Run icon. 

4.4 Stopping Execution of the Currently 
Executing Script 
To stop the currently executing script, click the Stop  icon or click Script>Run>Stop. 

You can then proceed to make edits to the script or run a new script.  

If you then click the Run icon, the script restarts from line 1. 
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Appendix A. – Script Commands 

The following conventions apply to these scripts: 

< >  Replace with required text argument. 

[  ]  Encloses optional arguments. 

CMD  Command name shown CAPITALIZED AND BOLD. 

For the simplest commands, you can select the commands and then enter arguments 
directly in the Command/Argument column of FBx Script Developer. For more complex 

commands, select the command and then click the command icon to launch the 
Command Arguments dialog box, and make your selections.  

A.1 Output File Commands 
Scripts can write to a local output file on the PC. The file can be used to log the 
progress/status of the script, or to write other information to the file. 

Note 
A script may only have one output file open at any time. 

A.1.1 OUTPUTFILE <Function> <Target file> 
Writes status or other information to a local file on the PC. 

<Function>  is one of the following: 

  WRITE  Open a new file for writing. 

  APPEND Append to an existing file. 

  CLOSE  Close the file. 

  DELETE  Delete the file. Can delete any file on the PC. 

<Target file> specifies the path and filename of the output file. The drive 
and folder must already exist. 
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Examples: 

The following command creates a new file on the PC called Scriptstatus.log in the 
C:\Myscripts folder: 

OUTPUTFILE WRITE C:\Myscripts\Scriptstatus.log  

The following command opens an existing file called Script27.txt in the folder C:\Myscripts 
for writing: 

OUTPUTFILE APPEND C:\Myscripts\Script27.txt 

The following command closes the file Script25. txt in the folder C:\Myscripts: 

OUTPUTFILE CLOSE C:\Myscripts\Script25.txt 

A.1.2 WRITE <Text> [<Text> ….] 
Writes each text argument to the currently open file. The text arguments are combined 
and separated with single spaces. 

<Text> Contiguous characters of text written to the output file. If there are 
multiple <text> arguments, each argument is written to the output file, 
with a space separating each argument from the next argument. 

 

Example: 

WRITE Write this text to the file.  
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A.1.3 WRITE_WITH_STAMP <Text> [<Text> ….] 
Writes the current time stamp to the currently open file, The text arguments are 
combined and separated with single spaces. 

<text> Contiguous characters of text written to the output file. If there are 
multiple <text> arguments, each argument is written to the output file, 
with a space separating each argument from the next argument. 

 

Example: 

WRITE_WITH_STAMP Write this text to the file. 

A.1.4 IMPORT <File path> 
Copies the contents of the specified text file and appends it to the end of the currently 
open output file. 

<File path> specifies the path and filename on the PC of the file to be 
appended to the currently open output file. The path and 
filename must exist. 

 

Example: 

To import the contents of mydatafile.txt into the current output file: 

IMPORT C:\>mydatafile.txt 
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A.1.1 DIR <Function> <Folder> 
Creates or deletes a folder on the PC. 

<Function>   is one of the following: 

 CREATE Creates a new folder. The name of the newly created 
folder is stored in the $DIR local variable> 

   DELETE  Deletes an existing folder. 

<Folder>  is the folder name on the PC. 

 

Examples: 

This creates a folder called logs in an existing folder called myfiles: 

DIR CREATE C:\myfiles\logs 

This deletes a folder called history from the C drive: 

DIR DELETE C:\history 

This creates a folder called “DailyReports”, and once created, lets you use the folder name 
(using the $DIR local variable) in another command, in this case, the ALARM_REPORT 
command: 

DIR CREATE C:\DailyReports 

ALARM_REPORT {$DIR}\Alarm CSV 

This would be equivalent to entering the command:  

ALARM_REPORT C:\DailyReports\Alarm CSV 
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A.1.2 ZIP <Folder to Zip> <Zip file name> 
Makes a compressed copy of a folder and its contents and stores it in a single file with the 
extension *.ZIP. 

<Folder to Zip>  The name of the folder to be compressed, including any sub-folders. 

<Zip file name> The name to assign to the zipped file. 

 

Example: 

To store a copy of the folder C:\myfiles\logs in a file called mylogs.zip:  

ZIP C:\myfiles\logs mylogs 

A.2 Script Control Commands 
These commands control operation of the script or external programs. 

A.2.1 RUN <File path> [<arg1> <arg2> …] 
Runs an external process with or without arguments. 

<File path>  specifies the path and filename of an executable (*.exe) 
program you want to start on the PC. 

[<arg1> <arg2> …]  one or more optional arguments for the executable 
program. 

 

Example: 

This command starts the Notepad application. 

 RUN c:\windows\notepad.exe 
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A.2.2 GOTO <Label> 
The order of script line execution jumps to the <label>. 

<Label> Name of a location in the script to jump to. The actual label 
location in the script must be preceded by a colon “:” 

 

Example: 

This jumps to the location of the script with the name “:Errorhandling” 

 GOTO Errorhandling 

In the actual script the label line would look like this: 

 

A.2.3 PAUSE <Number of seconds to wait> 
Pauses execution of the script for the specified number of seconds. 

<Number of seconds to wait> Number of seconds to pause the script. 

 

Example: 

This pauses the script for 60 seconds. 

PAUSE 60 
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A.2.4 ABORT [<Text>  <Text> … ] 
Stops execution of the script, and optionally writes text arguments to PC screen running 
the script. The text arguments are combined and separated with single spaces. 

<Text> Contiguous characters of text written to the output file. If 
there are multiple <text> arguments, each argument is 
written to the screen, with a space separating each 
argument from the next argument. 

 

Example: 

ABORT Script terminating now. 

A.2.5 EXIT [<Text>  <Text> … ] 
Stops execution of the script, and optionally writes text arguments to the PC screen 
running the script. The text arguments are combined and separated with single spaces.  

<Text> Contiguous characters of text written to the output file. If 
there are multiple <text> arguments, each argument is 
written to the screen, with a space separating each 
argument from the next argument. 

 

Example: 

EXIT Script completed successfully. 
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A.2.6 PROMPT <Message><Show entry text box><top button 
text><bottom button text> 
Opens a dialog box for the user with informational text provided by the <Message> 
argument.  

<Message> Text message to show the user in the dialog box. Must be 
enclosed in double quotes. 

<show entry text box> Show text entry field in the dialog box (yes/no).  

<top button text> Text to display in the top button. 

<bottom button text> Text to display in the bottom button. 

The following local variables are set based on user responses through the prompting 
dialog box: 

PROMPT   0 = User clicked the “No” button. (Bottom button) 

1 = User clicked the “Yes” button. (Top button). 

P_VAL   Value entered by the user in numeric format. 

$P_VAL   Value entered by the user in string format. 

 

Examples: 

Asking a “Yes” or “No” question: 

PROMPT “Do you want to continue?” no Yes No 

Results in the following prompt: 
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And stores the user’s Yes/No choice as a 1 (Yes) or 0 (No) in the PROMPT local 
variable: 

 

Asking a question requiring a numerical entry: 

PROMPT “Enter the run number you want to collect data for:” YES 

Results in the following prompt: 

 

And the user’s choice is stored in the P_VAL local variable: 

 

Asking a question requiring a string entry: 

PROMPT “Enter your name:” YES 

Results in the following prompt: 
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And the user’s choice is stored in the $P_VAL local variable: 

 

 

A.2.7 ECHO <Text>[ <Text> …] 
Writes text arguments to the PC screen running the script. The text arguments are 
combined and separated with single spaces.  

<Text> Contiguous characters of text written to the screen. If there 
are multiple <text> arguments, each argument is written to 
the screen, with a space separating each argument from the 
next argument. 

 

Example: 

 ECHO Data collection in progress… 

A.3 Local Variable Commands 
Scripts support local variables which you can reference inside the script. Script variable 
names are referenced by <var> in the following commands. If using a string variable, start 
the name with a dollar sign “$”.  
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A.3.1 VAR_SET <Destination Variable> <Value or Variable> 
Creates a local variable and sets its initial value. 

<Destination Variable> Name of the local variable, either a numeric variable or a 
string variable. 

<Value> Initial value to be assigned to the destination variable. This 
could be a numeric value or a string value. 

<Variable> Variable containing the initial value to be assigned to the 
destination variable. Could be a numeric value or a string 
value. String values must be surrounded by double quotation 
marks “ “. 

 

Examples: 

This creates a destination variable named “count” and sets its initial value to 0. 

  VAR_SET count 0 

This creates a string destination variable named “StationName” and sets it to the value 
“Ocean Drive”.  

  VAR_SET $StationName “Ocean Drive” 

This creates a destination variable named “count” and sets its initial value to the value of 
another variable named “total.” 

  VAR_SET count total 

A.3.2 VAR_ADD <Destination Variable> <Value or Variable> 
Adds a number or the value of a local numeric variable to the value of the destination 
local variable and stores the result in the destination variable. The variable(s) must exist, 
and must be numeric. 

<Destination Variable> Name of the destination numeric local variable. 
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<Value> An integer or floating point number to be assigned to the 
destination variable.  

<Variable> Variable containing an integer or floating point number to be 
assigned to the destination variable.  

 

Examples: 

This example adds 7 to the current value of the destination variable named “count.” 

VAR_ADD count 7 

This example adds the value of the “new” variable to the value of the destination variable 
“count.” 

  VAR_ADD count new 

A.3.3 VAR_SUB <Destination Variable> <Value or Variable> 
Subtracts a number or the numeric value of a local variable from the value of the 
destination variable and stores the result in the destination variable. The variable(s) must 
exist, and must be numeric. 

<Destination Variable> Name of the destination numeric local variable. 

<Value> An integer or floating point number to be subtracted from the 
destination variable.  

<Variable> Variable containing an integer or floating point number to be 
subtracted from the destination variable.  
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Examples: 

This example subtracts 5 from the current value of the variable named “count.” 

VAR_SUB count 5 

This example subtracts the value of the variable “daily” from the value of the variable 
“count.” 

  VAR_ADD count daily 

A.3.4 VAR_MULT <Destination Variable> <Value or Variable> 
Multiplies a number or the numeric value of a local variable by the value of the numeric 
destination variable and stores the result in the destination variable. The variable(s) must 
exist and must be numeric. 

<Destination Variable> Name of the destination numeric local variable. 

<Value> An integer or floating point number to be multiplied by the 
destination variable.  

<Variable> Variable containing an integer or floating point number to be 
multiplied by the destination variable.  

 

  



FBx Script Developer User Manual 
D301953X012 
November 2024 

 

34 Appendix A – Script Commands 

Examples: 

This example multiplies the current value of the variable named “total” by 5 and stores 
the result in “total.” 

VAR_MULT total 5 

This example subtracts the value of the variable “daily” from the value of the variable 
“total” and stores the result in “total.” 

  VAR_MULT total daily 

A.3.5 VAR_DIV <Destination Variable> <Value or Variable> 
Divides the value of the destination numeric local variable by a number or the value of 
another numeric local variable, then stores the result in the destination local variable. The 
variable(s) must exist and must be numeric. Attempts to divide by zero generate an 
“Attempted divide by 0” message in the status column. 

<Destination Variable> Name of the destination numeric local variable. 

<Value> An integer or floating point number by which the destination 
variable’s value is divided. 

<Variable> Variable containing an integer or floating point number by 
which the destination variable’s value is divided. 

 

Examples: 

This example divides the value of the destination variable “total” by 4. 

VAR_DIV total 4 

This example divides the value of the destination variable “daily” by the value of the 
variable “mf.” 

  VAR_DIV daily mf 
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A.3.6 VAR_DECR <Variable> 
Decrements a local variable by 1. The variable must exist and be numeric. 

<Variable>  Name of the numeric variable. 

 

Example: 

This example decrements the value of the variable “total” by 1. 

  VAR_DECR total 

A.3.7 VAR_INCR <Variable> 
Increments a local variable by 1. The variable must exist and be numeric. 

<Variable>  Name of the numeric variable. 

 

Example: 

This example increments the value of the variable “total” by 1. 

  VAR_INCR total 
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A.3.8 IF <Left Operand Variable> <Condition> <Right Operand 
Variable or Value> <Label to jump when condition is 
true> 
Checks the condition of a local variable and jumps to the label, if the condition is TRUE. 

<Left Operand Variable> Name of the numeric or string variable. 

<Condition> Must be a logical operator appropriate for whether “Variable” 
is numeric or string. 

 Table  A-1. Local Variable Conditional Operators 

Operator Description Variable  Data 
Types Supported 

EQ EQUAL Numeric, String 

NE NOT EQUAL Numeric, String 

GE GREATER THAN OR EQUAL Numeric 

GT GREATER THAN Numeric 

LE LESS THAN OR EQUAL Numeric 

LT LESS THAN Numeric 
 

<Right operand Variable or Value> Numerical or string variable or value. 

     <Label to jump when condition is true> Name of a location in the script to jump to. The actual 
location in the file must be preceded by a colon “:” 
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Examples: 

If “Total” is greater than “MyCount” then jump to the label named “DailyLog”: 

   IF MyCount GT Total DailyLog 

If “StationName” equals “Ocean Drive” then jump to the label named “Finish”: 

   IF StationName EQ “Ocean Drive” Finish 

A.4 Device Connection Command 

A.4.1 CONNECT <connection name> 
Establishes communication with an FB3000 RTU or an FB1000/FB2000-series flow 
computer through Field Tools. If the connection is successful, the software returns the 
product type and firmware version in a pair of local variables. 

Notes 
 Only one device connection can be active at any one time. If, after establishing a 

connection, you execute another CONNECT command, the existing connection is shut 
down, and the new CONNECT command then executes. 
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 If, instead of entering the connection name directly, you enter {$A1} in the script, it 
allows you to reuse the same script with different devices by specifying whatever 
device name you want when you invoke the script. 

Table  A-2. Local Variables Updated If the Connection is Successful 
Local Variable Name Description Local Variable Data Type 

$PRODUCT_TYPE Device type String 

$FRMWR_VERSION Firmware version String 
 

<connection name> The name of the connection, as it exists in Field Tools software. 
Field Tools must be running in order to establish communications. 

 

Examples: 

Establish communications between the script and the RTU using the connection name 
WESTMOOR. 

CONNECT WESTMOOR 

Use CONNECT in a script called MyCollectionScript using a parameter for the connection 
name instead of entering it directly: 

  CONNECT {$A1} 

When you invoke the script you can pass in the connection name, in this case 
“WESTFARMS”: 

 

  

A.5 Device System Commands 
These commands may only be used after a connection has been established through the 
CONNECT command. 
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A.5.1 WARM_START <Time to wait for device to reboot> 
Force the device to warm start. 

<Time to wait for device to reboot> The number of minutes to wait for the device to 
reboot. 

 

Example: 

To force the device to perform a warm start, and then wait 5 minutes for the warm start 
to complete. 

  WARM_START 5 

 

A.5.2 COLD_START <start type> <timeout> 
Force the device to cold start. 

<start type> Identifies an action to perform on the RTU/flow computer’s database. 

Table  A-3.  Start type’s Action on the Device database 
Start Type Value Description 

0 Leave database unchanged (default) 

1 Database is re-initialized with factory defaults. This restores User 
Data descriptions to factory defaults and clears 
alarm/event/history, user protocol maps, total, and averages. 
I/O modules also restart. 

2 Restore configuration from FLASH. Restore read/write database 
parameter values from flash memory. This restores User Data 
descriptions to factory defaults and clears alarm/event/history, 
user protocol maps, total, and averages. I/O modules also 
restart. 

 

<timeout> The number of minutes to wait for the device to reboot. 



FBx Script Developer User Manual 
D301953X012 
November 2024 

 

40 Appendix A – Script Commands 

 

Example: 

To force the device to perform a cold start, and then wait 7 minutes for the cold start to 
complete: 

  COLD_START 7 

A.5.3 TIME_SYNCH  
Synchronizes the time in the device with the PC’s local time. 

 

Examples: 

To synchronize the device’s time with the time on the PC: 

TIME_SYNCH 

A.6 Device Parameter Commands 
These commands allow you to read and write to parameters in the device. 
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A.6.1 READ_PARAM <Parameter name> <Variable name> 
Reads the value of a parameter on the device and stores it in a local variable for use in the 
script. 

<Parameter name> The full parameter name. If it contains spaces, it must be enclosed 
in double quotes. 

<Variable name> The local variable name. If it does not exist, it is created. If the 
parameter read contains a string, you must create a string local 
variable using the VAR_SET command. 

 

Example: 

Read analog input IoConfig_2.CHAN1_1_SELECT and store the value in a local variable 
called “Flow.” 

READ_PARAM IoConfig_2.CHAN1_1_SELECT Flow 

A.6.2 WRITE_PARAM <Parameter name> <Data type> <Value 
or Variable> 
Writes a value to a parameter in the device. 

<Parameter name> The full parameter name. If it contains spaces, it must be enclosed 
in double quotes “ “. 

<Data type> Device parameter data type. See Table A-4 for a list of valid 
parameter data types. 

<Value or Variable> Constant value or local variable. 
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Examples: 

Write the value 25.37 to the parameter User Data_1.FLOAT_1. 

WRITE_PARAM “User Data_1.FLOAT_1” FLOAT 25.37 

Write the string “Flow Totals” to the Hist_7.HIST_GROUP_OBJ.DESC parameter which is a 
20 character string type: 

  WRITE_PARM Hist_7.HIST_GROUP_OBJ.DESC UC20 “Flow Totals” 

Table  A-4.  WRITE_PARAM Data Types   
FBx Data Type Description 

UINT8 1-byte signed integer 

INT8 1-bytes unsigned integer 

UINT16 2-bytes signed integer 

INT16 2-bytes unsigned integer 

UINT32 4-bytes signed integer 

INT32 4-bytes unsigned integer 

UINT64 8-bytes unsigned integer 

INT64 8-bytes signed integer 

FLOAT Single-precision floating point number 

DOUBLE Double-precision floating point number 

UC10 10-byte character string 

UC20 20-byte character string 

UC30 30-byte character string 

UC40 40-byte character string 

BYTEARRY4 4 bytes 
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FBx Data Type Description 

BYTEARRAY6 6 bytes 

BYTEARRAY32 32 bytes 

TIME 8 bytes representing Julian time 

ENUM16 2 bytes enumeration code 

BIN8 8 bits 

BIN16 16 bits 

BIN32 32 bits 

PRMREF Parameter reference – 40 bytes maximum 

OBJREF Object reference – 20 bytes maximum 
 

A.6.3 RECIPE <Function> <Recipe file> 
The RECIPE command can perform two different operations, depending upon how the 
mode is set. 

<Function>  In READ mode, it reads a recipe file and then collects the values of 
those parameters from the device and updates the recipe file with 
those values.  

In WRITE mode, it reads a recipe file of parameters and values on the 
PC and then writes those values down to their corresponding 
parameters in the device. 

<Recipe file> Specifies the path and filename of the recipe file. Recipe files have an 
extension of (*.RCP). Each line of the recipe file consists of Parameter 
name, followed by a space, followed by the value of the parameter. 

Each line in the recipe file follows the format: 

Parameter_Name Data_Type Value 

For example, suppose you want to specify gas component parameters 
for an application, you could create a recipe called 
gascomponents.rcp. Each line of the recipe would specify the 
parameter, and, in this case, a double-precision floating point value for 
the given percentage of that component. The last line of the recipe 
automatically applies the components: 

Components_1.C1_OVRD,Double,94.6 
Components_1.N2_OVRD,Double,0.4 

Components_1.CO2_OVRD,Double,0.3 

Components_1.C2_OVRD,Double,4.4 
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Components_1.C3_OVRD,Double,0.2 

Components_1.H2O_OVRD,Double,0 

Components_1.H2S_OVRD,Double,0 

Components_1.H2_OVRD,Double,0.01 
Components_1.CO_OVRD,Double,0 

Components_1.O2_OVRD,Double,0.005 

Components_1.IC4_OVRD,Double,0.01 

Components_1.NC4_OVRD,Double,0.01 

Components_1.IC5_OVRD,Double,0.002 
Components_1.NEOC5_OVRD,Double,0 

Components_1.C6_OVRD,Double,0.002 

Components_1.C7_OVRD,Double,0 

Components_1.C8_OVRD,Double,0 

Components_1.C9_OVRD,Double,0 
Components_1.C10_OVRD,Double,0 

Components_1.HE_OVRD,Double,0 

Components_1.AR_OVRD,Double,0 

Components_1.BENZENE_OVRD,Double,0 
Components_1.TOLUENE_OVRD,Double,0 
Components_1.APPLY_COMP, Enum16, 1 

 

   

Examples: 

To write recipe values from the file OverrideGasComponents.rcp to parameters in the 
device: 

    RECIPE WRITE C:\OverrideGasComponents.rcp 

 To read values from the device and update the values in the recipe with those values: 

    RECIPE READ C:\MyOtherRecipe.rcp 

A.7 Device File Commands 
These commands are used with files stored on the RTU or flow computer.  
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Note 
In FBxConnect, you can go to Services > File Transfer to see a tree of the folders and files 
on the device. 

 

A.7.1 FILE_DELETE <Device file path> <File Not Found flag> 
Deletes a flash file from the device. 

<Device file path> Specifies the path and filename of the flash file on the device to 
be deleted. 

<File Not Found flag> This argument is optional. It indicates whether a file not found is 
reported as an error. 

0 File not found will be reported as success (default). 
1 File not found will be reported as an error. 

 

Example: 

To delete an FBxDesigner source file called Myproject.zwt from the device: 

    FILE_DELETE Myproject.zwt 

A.7.2 FILE_DOWNLOAD <PC file path> <Device file path> 
Downloads a file from the PC to the device flash area. 

<PC file path>    Specifies the path and filename of the file to be downloaded. 

<Device file path> Specifies the destination path in the flash area where the file will 
be copied. 
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Example: 

To download an FBxDesigner source file called Myproject.zwt to the device: 

    FILE_DOWNLOAD C:\myfiles\MyProject.zwt 

A.7.3 FILE_UPLOAD <Device file path> <PC file path> [<File 
Not Found flag>] 
Upload a flash file on the device to the PC. 

<device path>Specifies the path and filename on the device you want to upload. 

<PC file> Specifies destination path and filename for the uploaded file. 

<flag> This optional argument indicates whether a file not found will be reported 
as an error. 

  0 = File not found reported as success 

 1=File not found reported as an error (default)  
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Example: 

To upload an FBxDesigner source file called Myproject.zwt from the device: 

    FILE_UPLOAD Myproject.zwt C:\ProjectSource\Myproject.zwt 1 

 

A.8 Device Application Commands 

A.8.1 GET_APPS_INFO [<slot>] 
Retrieves information about applications running in the FB3000 such as the application 
name and version. This information returned is stored in local variables. 

<slot> Optional argument indicating the slot number, which must be an integer 
from 1 to 8. If specified, only retrieves details for the application in that slot. 

If not specified, details on all slots are retrieved. 
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Table  A-5.   Local Variable Holding Returned Device Application Information   
Local Variable Name Description Local Variable Data Type 

$APP_x_NAME The name of the application 
in slot x. STRING 

$APP_x_VERSION The version of the application 
in slot x. STRING 

$APP_x_SLOT The application slot. DOUBLE 
(x is replaced with the appropriate slot number) 

Examples: 

To retrieve detail on all installed applications: 

  GET_APPS_INFO 

To retrieve detail on only the application in slot 4: 

  GET_APPS_INFO 4 

A.8.2 APPLICATION <Function> <Slot> 
Starts or stops an IEC 61131 application in a particular slot on the FB3000 device. 

<Function>  Is one of the following: 

   START  Starts the application in the specified slot. 

   STOP  Stops the application in the specified slot. 

<Slot> Specifies the application software slot on the FB3000. Can be an 
integer from 1 and 8. 

 

Examples: 

To start the application in slot 2: 

 APPLICATION START 2 

To stop the application in slot 1: 

 APPLICATION STOP 1 
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A.9 Device Firmware Commands 
These commands relate to the system firmware running in the device.  

A.9.1 UPDATE_FIRMWARE <Firmware file> [<Time to wait for 
device to reboot>] 
Downloads a firmware zip file to the device.  

<Firmware file> The absolute path and filename of the firmware 
zip file. 

<Time to wait for device to reboot> Specifies how long (in minutes) to wait for the 
device to reboot after the firmware update. This 
argument is optional. If not specified, it defaults 
to 10 minutes. 

 

  Example: 

 Upgrade firmware to version 02_15_014_14 and wait 6 minutes for the reboot to occur 
before declaring an error. 

UPDATE_FIRMWARE C:\firmware\FB3000_SystemPackage_02_15_02_14.zip 6 

A.10 Solution Commands 
These commands can download or upload a solution file to or from the device.  

A.10.1 SOLUTION_UPLOAD <File path> 
Uploads a solution file from the device. 

<File path> Absolute path and filename on the PC to which the script tool 
should copy the solution file.  
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Example: 

To upload the solution file (mysoln.zsl) from the device, and store it in the folder c:\work: 

SOLUTION_UPLOAD C:\work\mysoln.zsl 

A.10.2 SOLUTION_DOWNLOAD <File path> 
Downloads a solution file to the connected device. 

<File path> Absolute path and filename on the PC where the solution file 
to be downloaded resides. 

 

Example: 

SOLUTION_DOWNLOAD C:\work\mysoln.zsl 

 

A.10.3 FLASH_DOWNLOAD <File path> 
Downloads a solution’s configuration to the device’s flash memory. 

<File path> Absolute path and name of the solution’s .ZSL configuration file 
to be downloaded into the flash memory area. 
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Example: 

FLASH_DOWNLOAD C:\work\mysoln.zsl 

A.10.4 PARTIAL_DOWNLOAD <File path> 
Downloads a partial configuration file to the device. 

<File path> Absolute path and name of the partial .PTC configuration file to be 
downloaded to the device. 

 

Example: 

PARTIAL_DOWNLOAD C:\work\myconfig.ptc 

A.10.5 PARTIAL_UPLOAD <Objects & Instances file> <Partial 
Configuration File> 
Reads an objects and instances CSV file on the PC and uses the entries in it to determine 
which objects and instances in the RTU should be included in a partial configuration file 
that the script will upload from the device. The ptc file does not contain read-only 
parameters. 

<Objects & Instances File> Absolute path and name of a file on the PC that 
contains a list of objects and instances in the device 
to be uploaded into a PTC file. This file requires an 
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extension of OIF. Each line of an OIF file has the 
format: 

 Object_  [instance number(s)]  To specify a range of 
instances, separate the top and bottom values of the 
range with an underscore “_”. If no instances are 
specified, all instances are uploaded. 

 Examples: 

1.  If a line in the OIF file looks like this: 

  PID_, 1, 2, 3 

Then PID objects 1, 2, and 3 are uploaded. 

2. If a line in the OIF file looks like this: 

Alarm_, 1000, 1005_1010 

Then Alarm instances 1000, 1005, 1006, 1007, 
1008, 1009, and 1010 will be uploaded. 

3. If a line in the OIF file looks like this: 

DP_, 1-1, 2-1 ,3-1 

Then DP objects 1-1, 2-1, and 3-1 are uploaded. 

4. If a line in the OIF file looks like this: 

HART_, 2-1, 2-9_2-12, 4-28 

Then HART instances 2-1, 2-9, 2-10, 2-11, 2-12, 
and 4-28 are uploaded. 

5. If a line in the OIF file looks like this: 

User Data_ 

Then because no instances are specified, all 
instances are uploaded. 

<Partial Configuration File> Absolute path and name of the partial .PTC 
configuration file on the PC that holds the uploaded 
objects and instances from the device. 
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Example: 

PARTIAL_UPLOAD C:\work\mystuff.OIF c:\work\myconfig.ptc 

 

A.10.6 FLASH_SAVE 
Saves the device’s configuration to flash. (Version 3.18 or newer) 

 

Example: 

FLASH_SAVE 

 

A.11 Device Report Generation Commands 
A.11.1 DIAG_REPORT <ClearDump or ReportType> <File Name> 

Uploads diagnostic records from the device and stores them in a report file on the PC. 

<ClearDump or ReportType> is one of the following: 

ClearDump clear memory dumps on the device 

DebugLog collect device’s debug log 

MemoryDump collect memory dumps in the device if they exist 
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SecurityLog collect device’s security log 

<File Name> Absolute path and name of the file which will hold the retrieved 
diagnostic records. Do not include the file extension. 

 

 

Example: 

 DIAG_REPORT SecurityLog C:\mydata\logons 

 

A.11.2 ALARM_REPORT <File Name> <Format> <Sorting> 
<Collection Period> [<From Time> <End_Time] 
Uploads alarm records from the device and stores them in a report file on the PC. 

<File Name> Absolute path and name of the file which will hold the retrieved alarm 
records. Do not include the file extension. 

<Format> Select the format of the report file: 

  PDF Portable document format 

  CSV Comma separated variable 

<Sorting> Specifies the order in which alarm records are stored in the alarm report 
file: 

 NEWTOOLD  Newest alarms appear at the top of the alarm report 
file. 

 OLDTONEW Oldest alarms appear at the bottom of the alarm 
report file. 
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<Collection period> Specifies which alarm records should be retrieved: 

ALL Retrieves all alarm records in the device. 

From Time Collect all alarm records between the from time 
and the current device timestamp. Timestamps are 
in the format: MM/DD/YYYY HH:mm:ss 

 

Time Range Retrieves all alarm records from the device between 
the From Time and end-time timestamps. 

End_time Specifies the end of the time range. 

 

Example: 

To collect all alarms between midnight and 8AM from May 18th 2024 and store them in a 
CSV file named alarmhistory in the folder C:\myalarms with the most recent alarms at the 
top of the file, enter: 

ALARM_REPORT c:\myalarms\alarmhistory CSV NEWTOOLD 05/18/24 00:00:00 5/18/24 
08:00:00 
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A.11.1 EVENT_REPORT <File Name> <Format> <Sorting> 
<Collection Period> [<From time> <End_time>] [<Sub-
type>] 
Uploads event records from the device and stores them in a report file on the PC. 

<File Name> Absolute path and name of the file which will hold the retrieved 
event records. Do not include the file extension. 

<Format> Select the format of the report file: 

 PDF Portable document format 

 CSV Comma separated variable 

<Sorting> Specifies the order in which event records are stored in the event 
report file: 

 NEWTOOLD  Newest events appear at the top of the event report 
file. 

 OLDTONEW Oldest events appear at the bottom of the event 
report file. 

<Collection Period> Specifies which event records should be retrieved: 

ALL Retrieves all event records in the device. 

From Time Collect all event records between the start time and 
the current device timestamp. Timestamps are in 
the format: MM/DD/YYYY HH:mm:ss 

Time Range Retrieves all event records from the device 
between the start_time and end-time timestamps. 

End_Time Specifies the end of the time range. 

<Sub-type> Optional argument: 

LEGAL Only collect event records considered “legal” by an 
auditing authority. 

NON-LEGAL Only collect event records considered “non-legal” by 
an auditing authority. 
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Example: 

To collect all legally specified events from midnight to 8AM on May 18, 2024 into a file 
called eventhistory.csv in the C:\myevents folder: 

EVENT_REPORT c:\myevents\eventhistory CSV NEWTOOLD 05/18/24 00:00:00 5/18/24 
08:00:00 LEGAL 

A.11.1 HISTORY_REPORT <File Name> <Format> <Sorting> 
<Collection Period> [<From time> <End_time>] <History 
Group(s)> <Interval(s)> 
Uploads history records from the device and stores them in a report file on the PC. 

<File Name> Absolute path and name of the file which will hold the retrieved 
history records. Do not include the file extension. 

<Format> Select the format of the report file: 

 PDF Portable document format 

 CSV Comma separated variable 

<Sorting> Specifies the order in which history records are stored in the 
report file: 

 NEWTOOLD  Newest records appear at the top of the history 
report file. 
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 OLDTONEW Oldest records appear at the bottom of the history 
report file. 

<Collection Period> Specifies which history records should be retrieved: 

ALL Retrieves all history records in the device. 

From Time Collect all history records between the start time 
and the current device timestamp. Timestamps are 
in the format: MM/DD/YYYY HH:mm:ss 

Time Range Retrieves all history records from the device 
between the start_time and end-time timestamps. 

End_Time Specifies the end of the time range. 

<History Group(s)> ALL Collects records for all history groups. 

 Specific  Single history group number as integer or multiple 
history group numbers separated by commas. 

<Intervals> Specify Hourly, Daily, Weekly, or Monthly, or specify multiple 
interval types separated by commas. 



FBx Script Developer User Manual 
D301953X012 

 November 2024 

Appendix A – Script Commands 59 

 

Example: 

To collect hourly and daily data from history groups 1, 2, and 3 and store it in the file 
historicalrecords.csv in the pre-existing folder “myhistory” with newest data shown first, 
enter: 

HISTORY_REPORT c:\myhistory\historicalrecords CSV NEWTOOLD 1,2,3 Hourly, Daily  

A.11.1 TRANSHISTORY_REPORT <File Name> <Format> 
<Sorting> <Collection Period> [<From time> 
<End_time>] <History Group(s)> <Sub-type(s)> 
Uploads transaction history records from the device and stores them in a report file on 
the PC. 

<File Name> Absolute path and name of the file which will hold the retrieved 
transaction history records. Do not include the file extension. 
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<Format> Select the format of the report file: 

 PDF Portable document format 

 CSV Comma separated variable 

<Sorting> Specifies the order in which transaction history records are stored 
in the report file: 

 NEWTOOLD  Newest records appear at the top of the transaction 
history report file. 

 OLDTONEW Oldest records appear at the bottom of the 
transaction history report file. 

<Collection Period> Specifies which transaction history records should be retrieved: 

ALL Retrieves all transaction history records in the 
device. 

From Time Collect all transaction history records between the 
start time and the current device timestamp. 
Timestamps are in the format: MM/DD/YYYY 
HH:mm:ss 

Time Range Retrieves all transaction history records from the 
device between the start_time and end-time 
timestamps.  

End_Time Specifies the end of the time range. 

<History Group(s)> ALL Collects transaction records for all history groups. 

 Specific  Single history group number as integer or multiple 
history group numbers separated by commas. 

<Sub-Types> Specify the categories of transactions to retrieve. Choices are:  
Batch, Hourly, Daily, Weekly, or Monthly, Snapshot or you can 
specify multiple categories separated by commas. 
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Example: 

To collect all batch transaction history records, from newest to oldest, and store them in 
the pre-existing “myhistory” folder in the file transactionrecords.CSV, enter: 

TRANSHISTORY_REPORT c:\myhistory\transactionrecords CSV NEWTOOLD ALL Batch 
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